rmagickをインストールしてもインストールした情報が読み込まれずに結構はまってしまいました

解決方法

まずはrmagickをアンインストールします
その後、bundle installして以下のような画面が出てこればおっけーです!

参考にした記事

解決に導いてくれた記事

How can I correctly uninstall gems from OSX’s system ruby 1.8.x while using rbenv + different ruby version?

試したこと一覧の記事

ImageMagick unable to start because of incompatible version of liblzma

RMagick complaining about libMagickCore.5.dylib not found in OSX
Rails – Can’t install RMagick 2.16.0. Can’t find MagickWand.h
RMagick installation: Can’t find MagickWand.h
Can’t install RMagick 2.13.1. Can’t find MagickWand.h.
RMagick errors when running Rake Tasks in OS X Maverick
Mountain Lionにアップグレード後にRMagickがエラーになる場合の対応
rmagickのインストールに失敗したときの対処方法
Library not loaded: /usr/local/lib/libMagickCore.4.dylib (LoadError) #9

warning: already initialized constant APP_PATH #259

bin/rails:6: warning: already initialized constant APP_PATH